about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@iosphe.re>2015-02-17 18:08:23 +0100
committerPaweł Jastrzębski <pawelj@iosphe.re>2015-02-17 18:08:23 +0100
commit68521f7c639d8f7675df4718c90bf5c932e82e3a (patch)
tree6f0b5dc1ced1902810c6dc51f20a3502aa6f03e3 /setup.py
parentGeneral refactoring and tweaks (diff)
downloadkcc-68521f7c639d8f7675df4718c90bf5c932e82e3a.tar.gz
kcc-68521f7c639d8f7675df4718c90bf5c932e82e3a.tar.bz2
kcc-68521f7c639d8f7675df4718c90bf5c932e82e3a.zip
Updated installer
Diffstat (limited to '')
-rwxr-xr-xsetup.py14
1 files changed, 10 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 35afa85..f650402 100755
--- a/setup.py
+++ b/setup.py
@@ -55,17 +55,23 @@ if platform == "darwin":
 elif platform == "win32":
     # noinspection PyUnresolvedReferences
     import py2exe
+    import platform
     from distutils.core import setup
-    additional_files = [('platforms', ['C:\Python34\Lib\site-packages\PyQt5\plugins\platforms\qwindows.dll']),
+    if platform.architecture()[0] == '64bit':
+        suffix = '_64'
+    else:
+        suffix = ''
+    additional_files = [('platforms', ['C:\Python34' + suffix +
+                                       '\Lib\site-packages\PyQt5\plugins\platforms\qwindows.dll']),
                         ('', ['LICENSE.txt',
                               'other\\7za.exe',
                               'other\\UnRAR.exe',
                               'other\\Additional-LICENSE.txt',
-                              'C:\Python34\Lib\site-packages\PyQt5\libGLESv2.dll',
-                              'C:\Python34\Lib\site-packages\PyQt5\libEGL.dll'])]
+                              'C:\Python34' + suffix + '\Lib\site-packages\PyQt5\libGLESv2.dll',
+                              'C:\Python34' + suffix + '\Lib\site-packages\PyQt5\libEGL.dll'])]
     extra_options = dict(
         options={'py2exe': {"bundle_files": 1,
-                            "dist_dir": "dist",
+                            "dist_dir": "dist" + suffix,
                             "compressed": True,
                             "includes": ["sip"],
                             "excludes": ["tkinter"],