about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@iosphe.re>2015-01-10 11:09:28 +0100
committerPaweł Jastrzębski <pawelj@iosphe.re>2015-01-10 11:09:28 +0100
commit98bf28a713a161466673d09f7c2f556757577ee7 (patch)
treeca88cc880d7f8f276286fd33afc9d54823b38860 /setup.py
parentFixed upgrade freeze (close #123) (diff)
downloadkcc-98bf28a713a161466673d09f7c2f556757577ee7.tar.gz
kcc-98bf28a713a161466673d09f7c2f556757577ee7.tar.bz2
kcc-98bf28a713a161466673d09f7c2f556757577ee7.zip
Fixed OSX GUI anomalies
Diffstat (limited to '')
-rwxr-xr-xsetup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index a75f07f..2d3698d 100755
--- a/setup.py
+++ b/setup.py
@@ -26,8 +26,7 @@ if platform == "darwin":
             py2app=dict(
                 argv_emulation=True,
                 iconfile='icons/comic2ebook.icns',
-                includes=['PIL', 'sip', 'PyQt5', 'PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtNetwork', 'PyQt5.QtWidgets',
-                          'PyQt5.QtPrintSupport'],
+                includes=['sip', 'PyQt5.QtPrintSupport'],
                 resources=['LICENSE.txt', 'other/qt.conf', 'other/Additional-LICENSE.txt', 'other/unrar', 'other/7za'],
                 plist=dict(
                     CFBundleName=NAME,
@@ -35,8 +34,6 @@ if platform == "darwin":
                     CFBundleGetInfoString=NAME + " " + VERSION +
                     ", written 2012-2015 by Ciro Mattia Gonano and Pawel Jastrzebski",
                     CFBundleExecutable=NAME,
-                    CFBundleIdentifier='com.github.ciromattia.kcc',
-                    CFBundleSignature='dplt',
                     CFBundleDocumentTypes=[
                         dict(
                             CFBundleTypeExtensions=['cbz', 'cbr', 'cb7', 'zip', 'rar', '7z', 'pdf'],