about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <30861839+Baitinq@users.noreply.github.com>2022-08-28 22:11:24 +0000
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-29 00:11:24 +0200
commitf4195828af618f3451b69a5c7ae09d2ecbdd5b72 (patch)
treeae04ae5afae4a599f06fe46cdb80beca54f27f18 /flake.nix
parentPackages: Remove xmonadctl (diff)
downloadnixos-config-f4195828af618f3451b69a5c7ae09d2ecbdd5b72.tar.gz
nixos-config-f4195828af618f3451b69a5c7ae09d2ecbdd5b72.tar.bz2
nixos-config-f4195828af618f3451b69a5c7ae09d2ecbdd5b72.zip
Implement non NixOS hosts support
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7948fd6..f997fa2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,5 +1,5 @@
 {
-  description = "My NixOS configuration";
+  description = "My Nix(\"OS\" or \"\") configuration";
 
   inputs = {
     nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
@@ -28,6 +28,14 @@
   outputs = inputs @ { self, nixpkgs, home-manager, ... }:
     {
       nixosConfigurations = import ./hosts {
+        isNixOS = true;
+        inherit (nixpkgs) lib;
+        inherit inputs nixpkgs home-manager;
+      };
+
+      homeConfigurations = import ./hosts {
+        isNixOS = false;
+        #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
       };