about summary refs log tree commit diff
path: root/hardware/laptop/disks.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-20 02:18:09 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-20 02:23:35 +0200
commitdaaf66420582db82f8cad09510324656d429d229 (patch)
treed335d4265669c7ad3dee658389bacda787830b42 /hardware/laptop/disks.nix
parentMisc: Remove code duplication by merging sets (diff)
downloadnixos-config-daaf66420582db82f8cad09510324656d429d229.tar.gz
nixos-config-daaf66420582db82f8cad09510324656d429d229.tar.bz2
nixos-config-daaf66420582db82f8cad09510324656d429d229.zip
Fully separate hosts from hardwares
Now hosts/ and hardware/ live under different directories and their
joined system configurations are permutated and exposed throught the
host-hardware outputs
Diffstat (limited to 'hardware/laptop/disks.nix')
-rw-r--r--hardware/laptop/disks.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/hardware/laptop/disks.nix b/hardware/laptop/disks.nix
new file mode 100644
index 0000000..07618df
--- /dev/null
+++ b/hardware/laptop/disks.nix
@@ -0,0 +1,52 @@
+{ config, lib, inputs, pkgs, modulesPath, isIso, ... }:
+{
+
+  environment.persistence."/persist" = {
+    directories = [
+      "/var/log"
+      "/var/lib"
+    ];
+    files = [
+      "/etc/machine-id"
+      "/etc/nix/id_rsa"
+    ];
+  };
+
+  fileSystems."/" = {
+    device = "none";
+    fsType = "tmpfs";
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/0A8B-3968";
+    fsType = "vfat";
+  };
+
+  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-uuid/6db0e43d-f73f-4cf0-81f6-9391f9d03ca0";
+
+  fileSystems."/persist" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/nix" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=home" "compress-force=zstd" ];
+  };
+
+  swapDevices = [ ];
+
+  services.btrfs.autoScrub.enable = true;
+
+  zramSwap.enable = true;
+
+}