about summary refs log tree commit diff
path: root/hosts/default.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-20 16:12:48 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-20 16:12:48 +0200
commit00b706095dad2bf169d36bf0fcdb50a8ff1fb5f5 (patch)
treee6caa732552252f2557f36bd24fa07e9b22fbf49 /hosts/default.nix
parentdotfiles: swaylock: Change ring and ring-key colors (diff)
downloadnixos-config-00b706095dad2bf169d36bf0fcdb50a8ff1fb5f5.tar.gz
nixos-config-00b706095dad2bf169d36bf0fcdb50a8ff1fb5f5.tar.bz2
nixos-config-00b706095dad2bf169d36bf0fcdb50a8ff1fb5f5.zip
Flake: Remove dotfiles input
Instead we use it directly. This removes a lot of hassle + limitations
with flake inputs from files
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 7d1a4f1..157bf1b 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -2,6 +2,8 @@
 let
   secrets = import ../secrets;
 
+  dotfiles = ../dotfiles;
+
   hosts = [
     { host = "phobos"; system = "x86_64-linux"; timezone = secrets.main_timezone; location = secrets.main_location; }
     { host = "luna"; system = "x86_64-linux"; timezone = secrets.main_timezone; location = secrets.main_location; }
@@ -27,7 +29,7 @@ let
           (import ../overlays)
         ];
       };
-      extraArgs = { inherit pkgs inputs isIso isHardware user secrets timezone location; hostname = host; };
+      extraArgs = { inherit pkgs inputs isIso isHardware user secrets dotfiles timezone location; hostname = host; };
       extraSpecialModules = extraModules ++ lib.optional isHardware  ../hardware/${hardware} ++ lib.optional isIso "${nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix";
     in
     if isNixOS