about summary refs log tree commit diff
path: root/hosts/home.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-19 15:58:52 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-19 15:58:52 +0200
commit763b2a81231348187a51bf6cc9cdc0fa7705404a (patch)
tree2ec0a31f0c204681c4d8ca6b4d353ac193c68da1 /hosts/home.nix
parentRefactor custom packages (diff)
downloadnixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.tar.gz
nixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.tar.bz2
nixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.zip
Refractor codebase
Diffstat (limited to 'hosts/home.nix')
-rw-r--r--hosts/home.nix82
1 files changed, 43 insertions, 39 deletions
diff --git a/hosts/home.nix b/hosts/home.nix
index ef9bb98..f47e625 100644
--- a/hosts/home.nix
+++ b/hosts/home.nix
@@ -3,42 +3,44 @@ let
   dotfiles = ../dotfiles;
 in
 {
-  home.username = "${user}";
-  home.homeDirectory = "/home/${user}";
+  home = {
+    username = "${user}";
+    homeDirectory = "/home/${user}";
 
-  home.packages = with pkgs; [
-    scrot
-    qemu
-    redshift
-    custom.xwinwrap
-    discord
-    mpv
-    sxiv
-    dwm
-    st
-    dmenu
-    unclutter
-    clipmenu
-    dunst
-    sxhkd
-    feh
-    custom.smart-wallpaper
-    custom.dwmbar
-    numlockx
-    surf
-    pavucontrol
-    light
-    polkit_gnome
-    progress
-    qbittorrent
-    xorg.xev
-    statix
-    custom.anime-downloader
-    custom.adl
-    custom.trackma
-    kcc
-    custom.kindlegen
-  ];
+    packages = with pkgs; [
+      scrot
+      qemu
+      redshift
+      custom.xwinwrap
+      discord
+      mpv
+      sxiv
+      dwm
+      st
+      dmenu
+      unclutter
+      clipmenu
+      dunst
+      sxhkd
+      feh
+      custom.smart-wallpaper
+      custom.dwmbar
+      numlockx
+      surf
+      pavucontrol
+      light
+      polkit_gnome
+      progress
+      qbittorrent
+      xorg.xev
+      statix
+      custom.anime-downloader
+      custom.adl
+      custom.trackma
+      kcc
+      custom.kindlegen
+    ];
+  };
 
   services.gpg-agent = {
     enable = true;
@@ -151,10 +153,12 @@ in
     };
   };
 
-  xdg.configFile."zathura/zathurarc".source = dotfiles + "/zathurarc";
-  xdg.configFile."sxhkd/".source = dotfiles + "/sxhkd/";
-  xdg.configFile."dunst/dunstrc".source = dotfiles + "/dunstrc";
-  xdg.configFile."dwmbar".source = dotfiles + "/dwmbar/";
+  xdg = {
+    configFile."zathura/zathurarc".source = dotfiles + "/zathurarc";
+    configFile."sxhkd/".source = dotfiles + "/sxhkd/";
+    configFile."dunst/dunstrc".source = dotfiles + "/dunstrc";
+    configFile."dwmbar".source = dotfiles + "/dwmbar/";
+  };
 
   home.file = {
     ".bash_profile".source = dotfiles + "/.bash_profile";