about summary refs log tree commit diff
path: root/hosts/home.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-04 11:48:31 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-05 14:12:47 +0200
commit834f19223d817258108ad780a1bde2058ab3ee17 (patch)
treed7e954b3424b247200b07f9058a0e0364600a51f /hosts/home.nix
parentfmt (diff)
downloadnixos-config-834f19223d817258108ad780a1bde2058ab3ee17.tar.gz
nixos-config-834f19223d817258108ad780a1bde2058ab3ee17.tar.bz2
nixos-config-834f19223d817258108ad780a1bde2058ab3ee17.zip
Switch windowmanager to xmonad
Diffstat (limited to 'hosts/home.nix')
-rw-r--r--hosts/home.nix20
1 files changed, 18 insertions, 2 deletions
diff --git a/hosts/home.nix b/hosts/home.nix
index c1df4c6..568f426 100644
--- a/hosts/home.nix
+++ b/hosts/home.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, inputs, user, hostname, secrets, ... }:
+{ config, lib, pkgs, inputs, user, hostname, secrets, location, ... }:
 let
   dotfiles = ../dotfiles;
 in
@@ -17,7 +17,7 @@ in
       discord
       mpv
       sxiv
-      dwm
+      #dwm
       st
       dmenu
       unclutter
@@ -41,6 +41,22 @@ in
     ]);
   };
 
+  xsession.windowManager.xmonad = {
+    enable = true;
+    enableContribAndExtras = true;
+    #extraPackages = pkgs: [pkgs.xmonadctl];
+    config = dotfiles + "/xmonad.hs";
+  };
+
+  programs.xmobar = {
+    enable = true;
+    extraConfig = builtins.readFile (dotfiles + "/xmobar.hs");
+  };
+
+  home.sessionVariables = {
+    LOCATION = "${location}";
+  };
+
   services = {
     gpg-agent = {
       enable = true;