about summary refs log tree commit diff
path: root/hosts/luna/default.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:05:58 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:26:21 +0200
commitf3b26a047b022e40bae171b635fdc2de9d78aec0 (patch)
tree3dca4c838e67f9426dcc559d67126487ce38e5bf /hosts/luna/default.nix
parentfmt (diff)
downloadnixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.gz
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.bz2
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.zip
Add luna host
Diffstat (limited to 'hosts/luna/default.nix')
-rw-r--r--hosts/luna/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/hosts/luna/default.nix b/hosts/luna/default.nix
new file mode 100644
index 0000000..c63c041
--- /dev/null
+++ b/hosts/luna/default.nix
@@ -0,0 +1,35 @@
+# Edit this configuration file to define what should be installed on
+# your system.  Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, lib, secrets, hostname, inputs, user, ... }: {
+
+  imports = [
+    # Include the results of the hardware scan.
+    ./hardware.nix
+  ];
+
+  services = {
+    # Configure keymap in X11
+    xserver.layout = "gb";
+    fstrim.enable = true;
+  };
+
+  # Pick only one of the below networking options.
+  networking = {
+    wireless = {
+      enable = true; # Enables wireless support via wpa_supplicant.
+      networks = secrets.wifi;
+    };
+    # networkmanager.enable = true;  # Easiest to use and most distros use this by default.
+    # Configure network proxy if necessary
+    # proxy.default = "http://user:password@proxy:port/";
+    # proxy.noProxy = "127.0.0.1,localhost,internal.domain";
+  };
+
+  environment.systemPackages = with pkgs;
+    [
+
+    ];
+}
+