about summary refs log tree commit diff
path: root/hosts/luna/disks.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:23:30 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:29:20 +0200
commitc084e56f4d1dff4dc7524617875dec2093531d77 (patch)
treee82f6b7d1d67013f863c9f607b0234cc3c9ace53 /hosts/luna/disks.nix
parentAdd wireguard secret module (diff)
downloadnixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.gz
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.bz2
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.zip
Separate disk related hardware config into disks.nix
Diffstat (limited to 'hosts/luna/disks.nix')
-rw-r--r--hosts/luna/disks.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/hosts/luna/disks.nix b/hosts/luna/disks.nix
new file mode 100644
index 0000000..753711c
--- /dev/null
+++ b/hosts/luna/disks.nix
@@ -0,0 +1,53 @@
+{ config, lib, inputs, pkgs, modulesPath, ... }:
+{
+  fileSystems."/" = {
+    device = "none";
+    fsType = "tmpfs";
+  };
+
+  boot.initrd.luks.devices."encrypted_boot" = {
+    device = "/dev/disk/by-uuid/4f5ba100-5c69-49ce-b0cf-2f219a5e9e51";
+    preLVM = true;
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/mapper/encrypted_boot";
+    fsType = "vfat";
+  };
+
+  fileSystems."/boot/efi" = {
+    device = "/dev/disk/by-uuid/BD51-1431";
+    fsType = "vfat";
+  };
+
+  boot.initrd.luks.devices."encrypted_nix".device = "/dev/disk/by-uuid/596e43d3-ccda-4f06-bce9-58d6a8c0dd79";
+
+  fileSystems."/nix" = {
+    device = "/dev/mapper/encrypted_nix";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
+  };
+
+  boot.initrd.luks.devices."encrypted_home_and_persist".device = "/dev/disk/by-uuid/47a8ddde-1237-4a0f-84c4-f17fbd22ea3f";
+
+  fileSystems."/persist" = {
+    device = "/dev/mapper/encrypted_home_and_persist";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/mapper/encrypted_home_and_persist";
+    fsType = "btrfs";
+    options = [ "subvol=home" "compress-force=zstd" ];
+  };
+
+  services.btrfs.autoScrub.enable = true;
+
+  swapDevices = [ ];
+
+  zramSwap.enable = true;
+
+}