about summary refs log tree commit diff
path: root/hosts/luna/hardware.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:05:58 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:26:21 +0200
commitf3b26a047b022e40bae171b635fdc2de9d78aec0 (patch)
tree3dca4c838e67f9426dcc559d67126487ce38e5bf /hosts/luna/hardware.nix
parentfmt (diff)
downloadnixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.gz
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.bz2
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.zip
Add luna host
Diffstat (limited to 'hosts/luna/hardware.nix')
-rw-r--r--hosts/luna/hardware.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/hosts/luna/hardware.nix b/hosts/luna/hardware.nix
new file mode 100644
index 0000000..ce34029
--- /dev/null
+++ b/hosts/luna/hardware.nix
@@ -0,0 +1,59 @@
+{ config, lib, pkgs, modulesPath, ... }:
+let
+  powerMode = "powersave";
+in
+{
+  imports = [ ];
+
+  boot = {
+    initrd = {
+      availableKernelModules = [ "xhci_pci" "usb_storage" "sd_mod" "sdhci_acpi" ];
+      kernelModules = [ ];
+    };
+    kernelModules = [ "kvm_intel" ];
+    extraModulePackages = [ ];
+    kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" ];
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/71B3-0F04";
+    fsType = "vfat";
+  };
+
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/af0f88f6-d4db-471e-b5b7-2c0a1c314c23";
+    fsType = "btrfs";
+    options = [ "subvol=root compress-force=zstd noatime" ];
+  };
+
+  fileSystems."/nix" = {
+    device = "/dev/disk/by-uuid/af0f88f6-d4db-471e-b5b7-2c0a1c314c23";
+    fsType = "btrfs";
+    options = [ "subvol=nix compress-force=zstd noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/disk/by-uuid/d7d4ebea-7c4b-4b1b-afdf-8b39f686276e";
+    fsType = "btrfs";
+    options = [ "subvol=home compress-force=zstd" ];
+  };
+
+  swapDevices = [ ];
+
+  powerManagement.cpuFreqGovernor = powerMode;
+
+  services.xserver = {
+    videoDrivers = [ "intel" ];
+
+    # Enable touchpad support (enabled default in most desktopManager).
+    libinput.enable = true;
+  };
+
+  hardware = {
+    opengl = {
+      enable = true;
+      driSupport = true;
+    };
+  };
+
+}