about summary refs log tree commit diff
path: root/hosts/luna/home.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:05:58 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-25 17:26:21 +0200
commitf3b26a047b022e40bae171b635fdc2de9d78aec0 (patch)
tree3dca4c838e67f9426dcc559d67126487ce38e5bf /hosts/luna/home.nix
parentfmt (diff)
downloadnixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.gz
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.tar.bz2
nixos-config-f3b26a047b022e40bae171b635fdc2de9d78aec0.zip
Add luna host
Diffstat (limited to 'hosts/luna/home.nix')
-rw-r--r--hosts/luna/home.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/luna/home.nix b/hosts/luna/home.nix
new file mode 100644
index 0000000..2198b63
--- /dev/null
+++ b/hosts/luna/home.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, inputs, user, hostname, secrets, ... }:
+{
+  home.packages = with pkgs; [
+    #minecraft
+    #jetbrains.idea-community
+    calibre
+    qtcreator
+    custom.anime-downloader
+    custom.adl
+    custom.trackma
+    custom.kindlegen
+    kcc
+  ];
+
+  xdg.configFile."dwmbar/config".text = ''
+    #!/bin/sh
+
+    # What modules, in what order
+    MODULES="weather wifi internet volume ram_perc cpuload cputemp battery date time"
+
+    # Modules that require an active internet connection
+    ONLINE_MODULES="weather internet"
+
+    # Delay between showing the status bar
+    DELAY="0.05"
+
+    # Where the custom modules are stored
+    CUSTOM_DIR="/home/$USER/.config/dwmbar/modules/custom/"
+
+    # Separator between modules
+    SEPARATOR=" | "
+
+    # Padding at the end and beggining of the status bar
+    RIGHT_PADDING=" "
+    LEFT_PADDING=" "
+  '';
+}