about summary refs log tree commit diff
path: root/hosts/phobos/disks.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-09 01:15:18 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-18 15:22:22 +0200
commit6795b5bd64c240cd989b2db12eb5c4652e48aecd (patch)
treeb1fed97244faeab8d58defcc28c9b388db06a50d /hosts/phobos/disks.nix
parentRiver: Change exit to Mod+Ctrl+Shift E (diff)
downloadnixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.gz
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.bz2
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.zip
Implement host-hardware separation
Diffstat (limited to 'hosts/phobos/disks.nix')
-rw-r--r--hosts/phobos/disks.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/hosts/phobos/disks.nix b/hosts/phobos/disks.nix
deleted file mode 100644
index 2927fe5..0000000
--- a/hosts/phobos/disks.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, lib, inputs, pkgs, modulesPath, isIso, ... }:
-{
-  fileSystems."/" = {
-    device = "none";
-    fsType = "tmpfs";
-  };
-
-  fileSystems."/boot" = {
-    device = "/dev/disk/by-uuid/0A8B-3968";
-    fsType = "vfat";
-  };
-
-  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-uuid/6db0e43d-f73f-4cf0-81f6-9391f9d03ca0";
-
-  fileSystems."/persist" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/nix" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/home" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=home" "compress-force=zstd" ];
-  };
-
-  swapDevices = [ ];
-
-  services.btrfs.autoScrub.enable = if !isIso then true else false;
-
-  zramSwap.enable = true;
-
-}