about summary refs log tree commit diff
path: root/hosts/phobos/hardware.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-19 15:58:52 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-19 15:58:52 +0200
commit763b2a81231348187a51bf6cc9cdc0fa7705404a (patch)
tree2ec0a31f0c204681c4d8ca6b4d353ac193c68da1 /hosts/phobos/hardware.nix
parentRefactor custom packages (diff)
downloadnixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.tar.gz
nixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.tar.bz2
nixos-config-763b2a81231348187a51bf6cc9cdc0fa7705404a.zip
Refractor codebase
Diffstat (limited to 'hosts/phobos/hardware.nix')
-rw-r--r--hosts/phobos/hardware.nix49
1 files changed, 31 insertions, 18 deletions
diff --git a/hosts/phobos/hardware.nix b/hosts/phobos/hardware.nix
index 6194c2d..84e9b8b 100644
--- a/hosts/phobos/hardware.nix
+++ b/hosts/phobos/hardware.nix
@@ -5,12 +5,16 @@ in
 {
   imports = [ ];
 
-  boot.initrd.availableKernelModules =
-    [ "xhci_pci" "ahci" "usbhid" "sd_mod" "sdhci_pci" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm_intel" ];
-  boot.extraModulePackages = [ ];
-  boot.kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" ];
+  boot = {
+    initrd = {
+      availableKernelModules =
+        [ "xhci_pci" "ahci" "usbhid" "sd_mod" "sdhci_pci" ];
+      kernelModules = [ ];
+    };
+    kernelModules = [ "kvm_intel" ];
+    extraModulePackages = [ ];
+    kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" ];
+  };
 
   fileSystems."/" = {
     device = "/dev/disk/by-uuid/2a0ba6f5-a4ec-4614-9bd2-11b4a66d5d82";
@@ -21,20 +25,29 @@ in
 
   powerManagement.cpuFreqGovernor = powerMode;
 
-  services.xserver.videoDrivers = [ "intel" ];
-  #  hardware.nvidia.modesetting.enable = true;
-  hardware.opengl.enable = true;
-  hardware.opengl.driSupport = true;
   #services.xserver.videoDrivers = [ "nvidia" ];
+  services.xserver = {
+    videoDrivers = [ "intel" ];
+    # Enable touchpad support (enabled default in most desktopManager).
+    libinput.enable = true;
+  };
+
+  hardware = {
+    opengl = {
+      enable = true;
+      driSupport = true;
+    };
 
-  /* hardware.nvidia.prime = {
-    sync.enable = true;
+    # nvidia.modesetting.enable = true;
+    /*nvidia.prime = {
+      sync.enable = true;
 
-    # Bus ID of the NVIDIA GPU. You can find it using lspci, either under 3D or VGA
-    nvidiaBusId = "PCI:1:0:0";
+      # Bus ID of the NVIDIA GPU. You can find it using lspci, either under 3D or VGA
+      nvidiaBusId = "PCI:1:0:0";
+
+      # Bus ID of the Intel GPU. You can find it using lspci, either under 3D or VGA
+      intelBusId = "PCI:0:2:0";
+      };*/
+  };
 
-    # Bus ID of the Intel GPU. You can find it using lspci, either under 3D or VGA
-    intelBusId = "PCI:0:2:0";
-    };
-  */
 }