about summary refs log tree commit diff
path: root/hosts/phobos/hardware.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:23:30 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:29:20 +0200
commitc084e56f4d1dff4dc7524617875dec2093531d77 (patch)
treee82f6b7d1d67013f863c9f607b0234cc3c9ace53 /hosts/phobos/hardware.nix
parentAdd wireguard secret module (diff)
downloadnixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.gz
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.bz2
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.zip
Separate disk related hardware config into disks.nix
Diffstat (limited to 'hosts/phobos/hardware.nix')
-rw-r--r--hosts/phobos/hardware.nix42
1 files changed, 4 insertions, 38 deletions
diff --git a/hosts/phobos/hardware.nix b/hosts/phobos/hardware.nix
index 0224fc5..cf95556 100644
--- a/hosts/phobos/hardware.nix
+++ b/hosts/phobos/hardware.nix
@@ -1,9 +1,11 @@
-{ config, lib, pkgs, modulesPath, ... }:
+{ config, lib, inputs, pkgs, modulesPath, ... }:
 let
   powerMode = "performance";
 in
 {
-  imports = [ ];
+  imports = [
+    ./disks.nix
+  ];
 
   boot = {
     initrd = {
@@ -15,39 +17,6 @@ in
     kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" "mitigations=off" ];
   };
 
-  fileSystems."/" = {
-    device = "none";
-    fsType = "tmpfs";
-  };
-
-  fileSystems."/boot" = {
-    device = "/dev/disk/by-uuid/0A8B-3968";
-    fsType = "vfat";
-  };
-
-  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-uuid/095dc267-9281-4535-9491-b3fcded614a8";
-
-  fileSystems."/persist" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/nix" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/home" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=home" "compress-force=zstd" ];
-  };
-
-  swapDevices = [ ];
-
   powerManagement.cpuFreqGovernor = powerMode;
 
   services = {
@@ -85,7 +54,4 @@ in
     };
   };
 
-  services.btrfs.autoScrub.enable = true;
-
-  zramSwap.enable = true;
 }