about summary refs log tree commit diff
path: root/hosts/phobos/hardware/laptop/disks.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-09 01:15:18 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-18 15:22:22 +0200
commit6795b5bd64c240cd989b2db12eb5c4652e48aecd (patch)
treeb1fed97244faeab8d58defcc28c9b388db06a50d /hosts/phobos/hardware/laptop/disks.nix
parentRiver: Change exit to Mod+Ctrl+Shift E (diff)
downloadnixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.gz
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.bz2
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.zip
Implement host-hardware separation
Diffstat (limited to '')
-rw-r--r--hosts/phobos/hardware/laptop/disks.nix (renamed from hosts/phobos/disks.nix)14
1 files changed, 13 insertions, 1 deletions
diff --git a/hosts/phobos/disks.nix b/hosts/phobos/hardware/laptop/disks.nix
index 2927fe5..07618df 100644
--- a/hosts/phobos/disks.nix
+++ b/hosts/phobos/hardware/laptop/disks.nix
@@ -1,5 +1,17 @@
 { config, lib, inputs, pkgs, modulesPath, isIso, ... }:
 {
+
+  environment.persistence."/persist" = {
+    directories = [
+      "/var/log"
+      "/var/lib"
+    ];
+    files = [
+      "/etc/machine-id"
+      "/etc/nix/id_rsa"
+    ];
+  };
+
   fileSystems."/" = {
     device = "none";
     fsType = "tmpfs";
@@ -33,7 +45,7 @@
 
   swapDevices = [ ];
 
-  services.btrfs.autoScrub.enable = if !isIso then true else false;
+  services.btrfs.autoScrub.enable = true;
 
   zramSwap.enable = true;