about summary refs log tree commit diff
path: root/hosts/phobos/hardware/laptop/disks.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-09 01:15:18 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-18 15:22:22 +0200
commit6795b5bd64c240cd989b2db12eb5c4652e48aecd (patch)
treeb1fed97244faeab8d58defcc28c9b388db06a50d /hosts/phobos/hardware/laptop/disks.nix
parentRiver: Change exit to Mod+Ctrl+Shift E (diff)
downloadnixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.gz
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.bz2
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.zip
Implement host-hardware separation
Diffstat (limited to 'hosts/phobos/hardware/laptop/disks.nix')
-rw-r--r--hosts/phobos/hardware/laptop/disks.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/hosts/phobos/hardware/laptop/disks.nix b/hosts/phobos/hardware/laptop/disks.nix
new file mode 100644
index 0000000..07618df
--- /dev/null
+++ b/hosts/phobos/hardware/laptop/disks.nix
@@ -0,0 +1,52 @@
+{ config, lib, inputs, pkgs, modulesPath, isIso, ... }:
+{
+
+  environment.persistence."/persist" = {
+    directories = [
+      "/var/log"
+      "/var/lib"
+    ];
+    files = [
+      "/etc/machine-id"
+      "/etc/nix/id_rsa"
+    ];
+  };
+
+  fileSystems."/" = {
+    device = "none";
+    fsType = "tmpfs";
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/0A8B-3968";
+    fsType = "vfat";
+  };
+
+  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-uuid/6db0e43d-f73f-4cf0-81f6-9391f9d03ca0";
+
+  fileSystems."/persist" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/nix" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=home" "compress-force=zstd" ];
+  };
+
+  swapDevices = [ ];
+
+  services.btrfs.autoScrub.enable = true;
+
+  zramSwap.enable = true;
+
+}