about summary refs log tree commit diff
path: root/hosts/phobos/home.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-24 18:54:08 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-06-24 18:54:08 +0200
commit0e5bb4c91acef18f2a3089346585d579c2d8c1df (patch)
treeb8cbef21bd857c81b6b90067e87783939a1625bf /hosts/phobos/home.nix
parentfmt (diff)
downloadnixos-config-0e5bb4c91acef18f2a3089346585d579c2d8c1df.tar.gz
nixos-config-0e5bb4c91acef18f2a3089346585d579c2d8c1df.tar.bz2
nixos-config-0e5bb4c91acef18f2a3089346585d579c2d8c1df.zip
Add host-specific dwmbar config
Diffstat (limited to 'hosts/phobos/home.nix')
-rw-r--r--hosts/phobos/home.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/phobos/home.nix b/hosts/phobos/home.nix
index a697850..4e177b3 100644
--- a/hosts/phobos/home.nix
+++ b/hosts/phobos/home.nix
@@ -11,4 +11,27 @@
     custom.kindlegen
     kcc
   ];
+
+  xdg.configFile."dwmbar/config".text = ''
+    #!/bin/sh
+
+    # What modules, in what order
+    MODULES="weather wifi internet volume ram_perc cpuload cputemp battery date time"
+
+    # Modules that require an active internet connection
+    ONLINE_MODULES="weather internet"
+
+    # Delay between showing the status bar
+    DELAY="0.05"
+
+    # Where the custom modules are stored
+    CUSTOM_DIR="/home/$USER/.config/dwmbar/modules/custom/"
+
+    # Separator between modules
+    SEPARATOR=" | "
+
+    # Padding at the end and beggining of the status bar
+    RIGHT_PADDING=" "
+    LEFT_PADDING=" "
+  '';
 }