about summary refs log tree commit diff
path: root/hosts/vm/hardware.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:23:30 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-22 02:29:20 +0200
commitc084e56f4d1dff4dc7524617875dec2093531d77 (patch)
treee82f6b7d1d67013f863c9f607b0234cc3c9ace53 /hosts/vm/hardware.nix
parentAdd wireguard secret module (diff)
downloadnixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.gz
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.tar.bz2
nixos-config-c084e56f4d1dff4dc7524617875dec2093531d77.zip
Separate disk related hardware config into disks.nix
Diffstat (limited to 'hosts/vm/hardware.nix')
-rw-r--r--hosts/vm/hardware.nix46
1 files changed, 4 insertions, 42 deletions
diff --git a/hosts/vm/hardware.nix b/hosts/vm/hardware.nix
index facdb18..7b04d70 100644
--- a/hosts/vm/hardware.nix
+++ b/hosts/vm/hardware.nix
@@ -1,6 +1,8 @@
-{ config, lib, pkgs, modulesPath, ... }:
+{ config, lib, inputs, pkgs, modulesPath, ... }:
 {
-  imports = [ ];
+  imports = [
+    ./disks.nix
+  ];
 
   boot = {
     initrd = {
@@ -13,46 +15,6 @@
     kernelParams = [ "net.ifnames=0" "biosdevname=0" "mitigations=off" ];
   };
 
-  fileSystems."/" = {
-    device = "none";
-    fsType = "tmpfs";
-  };
-
-  boot.initrd.luks.devices."encrypted_boot".device = "/dev/disk/by-partlabel/boot";
-
-  fileSystems."/boot" = {
-    device = "/dev/mapper/encrypted_boot";
-    fsType = "vfat";
-  };
-
-  fileSystems."/boot/efi" = {
-    device = "/dev/disk/by-partlabel/efi";
-    fsType = "vfat";
-  };
-
-  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-partlabel/root";
-
-  fileSystems."/nix" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/persist" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/home" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=home" "compress-force=zstd" ];
-  };
-
-  swapDevices = [ ];
-
   services.xserver = {
     # Enable touchpad support (enabled default in most desktopManager).
     libinput.enable = true;