about summary refs log tree commit diff
path: root/hosts/vm/hardware/virtualbox/hardware.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-09 01:15:18 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-18 15:22:22 +0200
commit6795b5bd64c240cd989b2db12eb5c4652e48aecd (patch)
treeb1fed97244faeab8d58defcc28c9b388db06a50d /hosts/vm/hardware/virtualbox/hardware.nix
parentRiver: Change exit to Mod+Ctrl+Shift E (diff)
downloadnixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.gz
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.bz2
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.zip
Implement host-hardware separation
Diffstat (limited to 'hosts/vm/hardware/virtualbox/hardware.nix')
-rw-r--r--hosts/vm/hardware/virtualbox/hardware.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/hosts/vm/hardware/virtualbox/hardware.nix b/hosts/vm/hardware/virtualbox/hardware.nix
new file mode 100644
index 0000000..470f733
--- /dev/null
+++ b/hosts/vm/hardware/virtualbox/hardware.nix
@@ -0,0 +1,33 @@
+{ config, lib, inputs, pkgs, modulesPath, ... }:
+{
+  imports = [
+    ./disks.nix
+  ];
+
+  boot = {
+    initrd = {
+      availableKernelModules =
+        [ "ata_piix" "ohci_pci" "sd_mod" "sr_mod" ];
+      kernelModules = [ ];
+    };
+    kernelPackages = pkgs.linuxPackages_latest;
+    kernelModules = [ ];
+    extraModulePackages = [ ];
+    kernelParams = [ "net.ifnames=0" "biosdevname=0" "mitigations=off" ];
+  };
+
+  services.xserver = {
+    # Enable touchpad support (enabled default in most desktopManager).
+    libinput.enable = true;
+  };
+
+  hardware = {
+    opengl = {
+      enable = true;
+      driSupport = true;
+    };
+  };
+
+  virtualisation.virtualbox.guest.enable = true;
+
+}