about summary refs log tree commit diff
path: root/overlays/base/default.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-26 20:09:07 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-26 20:09:07 +0200
commit28a9b39feccf10f409fe0c013458d950f2c566f3 (patch)
treec14bd0f309703431d4fcd7825a9036c73fab5a59 /overlays/base/default.nix
parentModule: Virtualisation: Replace docker with podman (diff)
downloadnixos-config-28a9b39feccf10f409fe0c013458d950f2c566f3.tar.gz
nixos-config-28a9b39feccf10f409fe0c013458d950f2c566f3.tar.bz2
nixos-config-28a9b39feccf10f409fe0c013458d950f2c566f3.zip
Overlays: Base: Grub2: Support luks2 with patch
Diffstat (limited to '')
-rw-r--r--overlays/base/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/overlays/base/default.nix b/overlays/base/default.nix
index f2773f6..5e2b0df 100644
--- a/overlays/base/default.nix
+++ b/overlays/base/default.nix
@@ -87,4 +87,10 @@ final: prev:
     });
   });
 
+  grub2 = prev.grub2.overrideAttrs (oldAttrs: {
+    patches = oldAttrs.patches ++ [
+      ./patches/grub-install_luks2.patch
+    ];
+  });
+
 }