about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index e5435fd..2becc78 100644
--- a/flake.nix
+++ b/flake.nix
@@ -37,6 +37,7 @@
         isNixOS = true;
         extraModules = [ ];
         isIso = false;
+        isHardware = true;
         inherit (nixpkgs) lib;
         inherit inputs user nixpkgs home-manager;
       };
@@ -45,6 +46,7 @@
         isNixOS = false;
         extraModules = [ ];
         isIso = false;
+        isHardware = false;
         #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs user nixpkgs home-manager;
@@ -54,10 +56,20 @@
         isNixOS = true;
         extraModules = [ ];
         isIso = true;
+        isHardware = false;
         user = "nixos";
         #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
       };
+
+      nixosNoHardwareConfigurations = import ./hosts {
+        isNixOS = true;
+        extraModules = [ ];
+        isIso = false;
+        isHardware = false;
+        inherit (nixpkgs) lib;
+        inherit inputs user nixpkgs home-manager;
+      };
     };
 }