about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7948fd6..f997fa2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,5 +1,5 @@
 {
-  description = "My NixOS configuration";
+  description = "My Nix(\"OS\" or \"\") configuration";
 
   inputs = {
     nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
@@ -28,6 +28,14 @@
   outputs = inputs @ { self, nixpkgs, home-manager, ... }:
     {
       nixosConfigurations = import ./hosts {
+        isNixOS = true;
+        inherit (nixpkgs) lib;
+        inherit inputs nixpkgs home-manager;
+      };
+
+      homeConfigurations = import ./hosts {
+        isNixOS = false;
+        #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
       };