about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index ad1ead9..de8a701 100644
--- a/flake.nix
+++ b/flake.nix
@@ -27,12 +27,25 @@
     {
       nixosConfigurations = import ./hosts {
         isNixOS = true;
+        extraModules = [ ];
+        isIso = false;
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
       };
 
       homeConfigurations = import ./hosts {
         isNixOS = false;
+        extraModules = [ ];
+        isIso = false;
+        #no COde duplication here: TODO
+        inherit (nixpkgs) lib;
+        inherit inputs nixpkgs home-manager;
+      };
+
+      isoConfigurations = import ./hosts {
+        isNixOS = true;
+        extraModules = [ ];
+        isIso = true;
         #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;