about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 3d61545..7338341 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,9 +26,27 @@
   outputs = inputs @ { self, nixpkgs, home-manager, ... }:
     let
       user = "baitinq";
+
+      secrets = import ./secrets;
+
+      dotfiles = ./dotfiles;
+
+      hosts = [
+        { host = "phobos"; system = "x86_64-linux"; extraOverlays = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
+        { host = "luna"; system = "x86_64-linux"; extraOverlays = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
+      ];
+
+      hardwares = [
+        { hardware = "laptop"; }
+        { hardware = "chromebook"; }
+        { hardware = "virtualbox"; }
+      ];
+
+
       commonInherits = {
         inherit (nixpkgs) lib;
-        inherit inputs user nixpkgs home-manager;
+        inherit inputs nixpkgs home-manager;
+        inherit user secrets dotfiles hosts hardwares;
         extraModules = [ ];
       };
     in