about summary refs log tree commit diff
path: root/hardware/virtualbox/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware/virtualbox/disks.nix')
-rw-r--r--hardware/virtualbox/disks.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/hardware/virtualbox/disks.nix b/hardware/virtualbox/disks.nix
new file mode 100644
index 0000000..6ba15ec
--- /dev/null
+++ b/hardware/virtualbox/disks.nix
@@ -0,0 +1,57 @@
+{ config, lib, inputs, pkgs, modulesPath, ... }:
+{
+
+  environment.persistence."/persist" = {
+    directories = [
+      "/var/log"
+      "/var/lib"
+    ];
+    files = [
+      "/etc/machine-id"
+      "/etc/nix/id_rsa"
+    ];
+  };
+
+  fileSystems."/" = {
+    device = "none";
+    fsType = "tmpfs";
+  };
+
+  boot.initrd.luks.devices."encrypted_boot".device = "/dev/disk/by-partlabel/boot";
+
+  fileSystems."/boot" = {
+    device = "/dev/mapper/encrypted_boot";
+    fsType = "vfat";
+  };
+
+  fileSystems."/boot/efi" = {
+    device = "/dev/disk/by-partlabel/efi";
+    fsType = "vfat";
+  };
+
+  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-partlabel/root";
+
+  fileSystems."/nix" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/persist" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=home" "compress-force=zstd" ];
+  };
+
+  swapDevices = [ ];
+
+  zramSwap.enable = true;
+
+}