about summary refs log tree commit diff
path: root/hardware/virtualbox/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hardware/virtualbox/hardware.nix')
-rw-r--r--hardware/virtualbox/hardware.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/hardware/virtualbox/hardware.nix b/hardware/virtualbox/hardware.nix
new file mode 100644
index 0000000..470f733
--- /dev/null
+++ b/hardware/virtualbox/hardware.nix
@@ -0,0 +1,33 @@
+{ config, lib, inputs, pkgs, modulesPath, ... }:
+{
+  imports = [
+    ./disks.nix
+  ];
+
+  boot = {
+    initrd = {
+      availableKernelModules =
+        [ "ata_piix" "ohci_pci" "sd_mod" "sr_mod" ];
+      kernelModules = [ ];
+    };
+    kernelPackages = pkgs.linuxPackages_latest;
+    kernelModules = [ ];
+    extraModulePackages = [ ];
+    kernelParams = [ "net.ifnames=0" "biosdevname=0" "mitigations=off" ];
+  };
+
+  services.xserver = {
+    # Enable touchpad support (enabled default in most desktopManager).
+    libinput.enable = true;
+  };
+
+  hardware = {
+    opengl = {
+      enable = true;
+      driSupport = true;
+    };
+  };
+
+  virtualisation.virtualbox.guest.enable = true;
+
+}