about summary refs log tree commit diff
path: root/hosts/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/configuration.nix')
-rw-r--r--hosts/configuration.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/hosts/configuration.nix b/hosts/configuration.nix
index 63a78c4..f8d6437 100644
--- a/hosts/configuration.nix
+++ b/hosts/configuration.nix
@@ -60,6 +60,9 @@
     isNormalUser = true;
     extraGroups = [ "wheel" "audio" "video" ]; # Enable ‘sudo’ for the user.
     hashedPassword = secrets.baitinq.hashed_password;
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAID99gQ/AgXhgwAjs+opsRXMbWpXFRT2aqAOUbN3DsrhQ (none)"
+    ];
   };
 
   environment.variables = {
@@ -129,6 +132,9 @@
   services = {
     openssh = {
       enable = true;
+      /* DOESNT WORK BECAUSE OF AUTHORIZEDKEYS BUG
+      passwordAuthentication = false;
+      kbdInteractiveAuthentication = false;*/
       listenAddresses = [{
         addr = "0.0.0.0";
         port = 2222;