about summary refs log tree commit diff
path: root/hosts/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/configuration.nix')
-rw-r--r--hosts/configuration.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/hosts/configuration.nix b/hosts/configuration.nix
index fba0f28..0b59af3 100644
--- a/hosts/configuration.nix
+++ b/hosts/configuration.nix
@@ -40,11 +40,9 @@
     hostName = hostname; # Define your hostname.
     enableIPv6 = true;
     extraHosts = builtins.readFile "${dotfiles}/hosts";
-    dhcpcd = {
-      enable = true;
-      extraConfig = "nohook resolv.conf";
-    };
-    resolvconf.enable = false;
+    dhcpcd.enable = true;
+    resolvconf.enable = true;
+    nameservers = [ "127.0.0.1" ];
     firewall = {
       enable = true;
       allowedTCPPorts = [ 80 22 9090 ];