about summary refs log tree commit diff
path: root/hosts/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/configuration.nix')
-rw-r--r--hosts/configuration.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/hosts/configuration.nix b/hosts/configuration.nix
index 5dfbbbc..e73f22d 100644
--- a/hosts/configuration.nix
+++ b/hosts/configuration.nix
@@ -1,4 +1,5 @@
-{ secrets, dotfiles, lib, pkgs, config, hostname, inputs, user, timezone, system, ... }: {
+{ secrets, dotfiles, lib, pkgs, config, hostname, inputs, user, timezone, system, stateVersion, ... }:
+{
 
   imports = [
     "${inputs.impermanence}/nixos.nix"
@@ -224,6 +225,6 @@
   # this value at the release version of the first install of this system.
   # Before changing this value read the documentation for this option
   # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
-  system.stateVersion = "22.05"; # Did you read the comment?
+  system.stateVersion = stateVersion; # Did you read the comment?
 }