about summary refs log tree commit diff
path: root/hosts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 7d1a4f1..157bf1b 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -2,6 +2,8 @@
 let
   secrets = import ../secrets;
 
+  dotfiles = ../dotfiles;
+
   hosts = [
     { host = "phobos"; system = "x86_64-linux"; timezone = secrets.main_timezone; location = secrets.main_location; }
     { host = "luna"; system = "x86_64-linux"; timezone = secrets.main_timezone; location = secrets.main_location; }
@@ -27,7 +29,7 @@ let
           (import ../overlays)
         ];
       };
-      extraArgs = { inherit pkgs inputs isIso isHardware user secrets timezone location; hostname = host; };
+      extraArgs = { inherit pkgs inputs isIso isHardware user secrets dotfiles timezone location; hostname = host; };
       extraSpecialModules = extraModules ++ lib.optional isHardware  ../hardware/${hardware} ++ lib.optional isIso "${nixpkgs}/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix";
     in
     if isNixOS