about summary refs log tree commit diff
path: root/hosts/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/default.nix')
-rw-r--r--hosts/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/hosts/default.nix b/hosts/default.nix
index 0005227..972b4af 100644
--- a/hosts/default.nix
+++ b/hosts/default.nix
@@ -1,5 +1,10 @@
 { user, lib, nixpkgs, nur, inputs, home-manager, ... }:
 let
+  hosts = [
+    { hostname = "baitinq"; system = "x86_64-linux"; }
+    { hostname = "vm"; system = "x86_64-linux"; }
+  ];
+
   mkHost = hostname: system:
     let
       pkgs = import nixpkgs {
@@ -32,11 +37,6 @@ let
       ];
     };
 in
-let hosts = [
-  { hostname = "baitinq"; system = "x86_64-linux"; }
-  { hostname = "vm"; system = "x86_64-linux"; }
-];
-in
   /*
     We have a list of sets.
     Map each element of the list applying the mkHost function to its elements and returning a set in the listToAttrs format