about summary refs log tree commit diff
path: root/hosts/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/home.nix')
-rw-r--r--hosts/home.nix20
1 files changed, 18 insertions, 2 deletions
diff --git a/hosts/home.nix b/hosts/home.nix
index c1df4c6..568f426 100644
--- a/hosts/home.nix
+++ b/hosts/home.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, inputs, user, hostname, secrets, ... }:
+{ config, lib, pkgs, inputs, user, hostname, secrets, location, ... }:
 let
   dotfiles = ../dotfiles;
 in
@@ -17,7 +17,7 @@ in
       discord
       mpv
       sxiv
-      dwm
+      #dwm
       st
       dmenu
       unclutter
@@ -41,6 +41,22 @@ in
     ]);
   };
 
+  xsession.windowManager.xmonad = {
+    enable = true;
+    enableContribAndExtras = true;
+    #extraPackages = pkgs: [pkgs.xmonadctl];
+    config = dotfiles + "/xmonad.hs";
+  };
+
+  programs.xmobar = {
+    enable = true;
+    extraConfig = builtins.readFile (dotfiles + "/xmobar.hs");
+  };
+
+  home.sessionVariables = {
+    LOCATION = "${location}";
+  };
+
   services = {
     gpg-agent = {
       enable = true;