about summary refs log tree commit diff
path: root/hosts/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/home.nix')
-rw-r--r--hosts/home.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/hosts/home.nix b/hosts/home.nix
index f332c7a..2efd78d 100644
--- a/hosts/home.nix
+++ b/hosts/home.nix
@@ -117,6 +117,9 @@
         signByDefault = true;
         key = "18BE4F736F27FC190C1E1000BB3C0BC698650937";
       };
+      aliases = {
+        pr = "!f() { git fetch -fu \${2:-origin} refs/pull/$1/head:pr/$1 && git checkout pr/$1; }; f";
+      };
       extraConfig = {
         push.autoSetupRemote = true;
         init.defaultBranch = "master";