about summary refs log tree commit diff
path: root/hosts/luna/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/luna/default.nix')
-rw-r--r--hosts/luna/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hosts/luna/default.nix b/hosts/luna/default.nix
index 23f4a07..d974306 100644
--- a/hosts/luna/default.nix
+++ b/hosts/luna/default.nix
@@ -34,5 +34,22 @@
   environment.systemPackages = with pkgs; [
     xf86_input_cmt #chromebook touchpad drivers
   ];
+
+  nix = {
+    distributedBuilds = true;
+    # optional, useful when the builder has a faster internet connection than yours
+    extraOptions = "builders-use-substitutes = true";
+    buildMachines = [{
+      hostName = "builder";
+      system = "x86_64-linux";
+      # if the builder supports building for multiple architectures,
+      # replace the previous line by, e.g.,
+      # systems = ["x86_64-linux" "aarch64-linux"];
+      maxJobs = 4;
+      speedFactor = 2;
+      supportedFeatures = [ "nixos-test" "benchmark" "big-parallel" "kvm" ];
+      mandatoryFeatures = [ ];
+    }];
+  };
 }