about summary refs log tree commit diff
path: root/hosts/luna/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/luna/disks.nix')
-rw-r--r--hosts/luna/disks.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/hosts/luna/disks.nix b/hosts/luna/disks.nix
index d9a5846..e8341da 100644
--- a/hosts/luna/disks.nix
+++ b/hosts/luna/disks.nix
@@ -9,8 +9,8 @@ let
         partitions = [
           {
             type = "partition";
-            part-type = "ESP";
-            label = "efi";
+            part-label = "efi";
+            flags = [ "esp" ];
             start = "0";
             end = "64M";
             fs-type = "fat32";
@@ -24,8 +24,7 @@ let
             type = "partition";
             start = "64M";
             end = "264M";
-            part-type = "primary";
-            label = "boot";
+            part-label = "boot";
             content = {
               type = "luks";
               name = "encrypted_boot";
@@ -41,8 +40,7 @@ let
             type = "partition";
             start = "264M";
             end = "100%";
-            part-type = "primary";
-            label = "nix";
+            part-label = "nix";
             content = {
               type = "luks";
               name = "encrypted_nix";
@@ -62,8 +60,7 @@ let
         partitions = [
           {
             type = "partition";
-            part-type = "primary";
-            label = "home_and_persist";
+            part-label = "home_and_persist";
             start = "0";
             end = "100%";
             content = {