about summary refs log tree commit diff
path: root/hosts/luna/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/luna/hardware.nix')
-rw-r--r--hosts/luna/hardware.nix55
1 files changed, 4 insertions, 51 deletions
diff --git a/hosts/luna/hardware.nix b/hosts/luna/hardware.nix
index 1d87654..da1416a 100644
--- a/hosts/luna/hardware.nix
+++ b/hosts/luna/hardware.nix
@@ -1,9 +1,11 @@
-{ config, lib, pkgs, modulesPath, ... }:
+{ config, lib, inputs, pkgs, modulesPath, ... }:
 let
   powerMode = "schedutil";
 in
 {
-  imports = [ ];
+  imports = [
+    ./disks.nix
+  ];
 
   boot = {
     initrd = {
@@ -15,52 +17,6 @@ in
     kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" "mitigations=off" ];
   };
 
-  fileSystems."/" = {
-    device = "none";
-    fsType = "tmpfs";
-  };
-
-  boot.initrd.luks.devices."encrypted_boot" = {
-    device = "/dev/disk/by-uuid/4f5ba100-5c69-49ce-b0cf-2f219a5e9e51";
-    preLVM = true;
-  };
-
-  fileSystems."/boot" = {
-    device = "/dev/mapper/encrypted_boot";
-    fsType = "vfat";
-  };
-
-  fileSystems."/boot/efi" = {
-    device = "/dev/disk/by-uuid/BD51-1431";
-    fsType = "vfat";
-  };
-
-  boot.initrd.luks.devices."encrypted_nix".device = "/dev/disk/by-uuid/596e43d3-ccda-4f06-bce9-58d6a8c0dd79";
-
-  fileSystems."/nix" = {
-    device = "/dev/mapper/encrypted_nix";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
-  };
-
-  boot.initrd.luks.devices."encrypted_home_and_persist".device = "/dev/disk/by-uuid/47a8ddde-1237-4a0f-84c4-f17fbd22ea3f";
-
-  fileSystems."/persist" = {
-    device = "/dev/mapper/encrypted_home_and_persist";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/home" = {
-    device = "/dev/mapper/encrypted_home_and_persist";
-    fsType = "btrfs";
-    options = [ "subvol=home" "compress-force=zstd" ];
-  };
-
-  swapDevices = [ ];
-
   powerManagement.cpuFreqGovernor = powerMode;
 
   services = {
@@ -94,7 +50,4 @@ in
     };
   };
 
-  services.btrfs.autoScrub.enable = true;
-
-  zramSwap.enable = true;
 }