about summary refs log tree commit diff
path: root/hosts/luna/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/luna/home.nix')
-rw-r--r--hosts/luna/home.nix76
1 files changed, 76 insertions, 0 deletions
diff --git a/hosts/luna/home.nix b/hosts/luna/home.nix
index 43aecfd..1523495 100644
--- a/hosts/luna/home.nix
+++ b/hosts/luna/home.nix
@@ -1,4 +1,7 @@
 { config, lib, pkgs, inputs, user, hostname, secrets, ... }:
+let
+  dotfiles = ../../dotfiles;
+in
 {
   home.packages = with pkgs; [
     #minecraft
@@ -42,6 +45,79 @@
       LEFT_PADDING=" "
     '';
 
+    "sxhkd/sxhkdrc".text =
+      builtins.readFile (dotfiles + "/sxhkd/dwm") +
+      builtins.readFile (dotfiles + "/sxhkd/base") +
+      ''
+            #enter and leave game mode
+        alt + shift + F11: ctrl + shift + F11 
+            pkill -ALRM sxhkd
+
+        # Make sxhkd reload its configuration files
+        alt + Escape
+        	pkill -USR1 -x sxhkd
+
+        #Screenshot
+        alt + grave
+                bash ~/.scripts/screenshot
+
+
+        ##################
+        ##### VOLUME #####
+        ##################
+
+        # Raise volume
+        XF86AudioRaiseVolume
+          amixer sset Master 5%+
+        	#pactl set-sink-volume 0 +5%
+
+        # Lower volume
+        XF86AudioLowerVolume
+          amixer sset Master 5%-
+        	#pactl set-sink-volume 0 -5%
+
+        # Mute audio
+        # note: mute always sets audio off (toggle)
+        XF86AudioMute
+          amixer sset Master toggle
+        	#pactl set-sink-mute 0 toggle
+
+
+        ######################
+        ##### BRIGHTNESS #####
+        ######################
+
+        XF86MonBrightnessUp
+          light -A 5
+
+        XF86MonBrightnessDown
+          light -U 5
+
+        ######################
+        ######## MEDIA #######
+        ######################
+
+        XF86AudioPlay
+          playerctl play
+
+        XF86AudioPause
+          playerctl pause
+
+        XF86AudioNext
+          playerctl next
+
+        XF86AudioPrev
+          playerctl previous
+
+        ######################
+        ######## OTHER #######
+        ######################
+
+        XF86TouchpadToggle
+        	exec ~/.config/i3/scripts/toggletouchpad.sh
+
+      '';
+
     "mpv/mpv.conf".text = ''
       ytdl-format=bestvideo[height<=?720][fps<=?60][vcodec!=?vp9]+bestaudio/best
       hwdec