about summary refs log tree commit diff
path: root/hosts/phobos/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/phobos/default.nix')
-rw-r--r--hosts/phobos/default.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/hosts/phobos/default.nix b/hosts/phobos/default.nix
index cbefcba..9871b91 100644
--- a/hosts/phobos/default.nix
+++ b/hosts/phobos/default.nix
@@ -13,13 +13,16 @@
   boot.loader.grub.device = "/dev/sdb"; # or "nodev" for efi only
 
   # Pick only one of the below networking options.
-  networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
-  networking.wireless.networks = secrets.wifi;
-  # networking.networkmanager.enable = true;  # Easiest to use and most distros use this by default.
-
-  # Configure network proxy if necessary
-  # networking.proxy.default = "http://user:password@proxy:port/";
-  # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
+  networking = {
+    wireless = {
+      enable = true; # Enables wireless support via wpa_supplicant.
+      networks = secrets.wifi;
+    };
+    # networkmanager.enable = true;  # Easiest to use and most distros use this by default.
+    # Configure network proxy if necessary
+    # proxy.default = "http://user:password@proxy:port/";
+    # proxy.noProxy = "127.0.0.1,localhost,internal.domain";
+  };
 
   environment.systemPackages = with pkgs;
     [