about summary refs log tree commit diff
path: root/hosts/phobos/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/phobos/disks.nix')
-rw-r--r--hosts/phobos/disks.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hosts/phobos/disks.nix b/hosts/phobos/disks.nix
index 9f1906e..6f005bf 100644
--- a/hosts/phobos/disks.nix
+++ b/hosts/phobos/disks.nix
@@ -1,4 +1,4 @@
-{ config, lib, inputs, pkgs, modulesPath, ... }:
+{ config, lib, inputs, pkgs, modulesPath, isIso, ... }:
 {
   fileSystems."/" = {
     device = "none";
@@ -33,7 +33,7 @@
 
   swapDevices = [ ];
 
-  services.btrfs.autoScrub.enable = true;
+  services.btrfs.autoScrub.enable = if !isIso then true else false;
 
   zramSwap.enable = true;