about summary refs log tree commit diff
path: root/hosts/phobos/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/phobos/disks.nix')
-rw-r--r--hosts/phobos/disks.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/hosts/phobos/disks.nix b/hosts/phobos/disks.nix
new file mode 100644
index 0000000..9f1906e
--- /dev/null
+++ b/hosts/phobos/disks.nix
@@ -0,0 +1,40 @@
+{ config, lib, inputs, pkgs, modulesPath, ... }:
+{
+  fileSystems."/" = {
+    device = "none";
+    fsType = "tmpfs";
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/0A8B-3968";
+    fsType = "vfat";
+  };
+
+  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-uuid/095dc267-9281-4535-9491-b3fcded614a8";
+
+  fileSystems."/persist" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    neededForBoot = true;
+    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/nix" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/mapper/encrypted_root";
+    fsType = "btrfs";
+    options = [ "subvol=home" "compress-force=zstd" ];
+  };
+
+  swapDevices = [ ];
+
+  services.btrfs.autoScrub.enable = true;
+
+  zramSwap.enable = true;
+
+}