about summary refs log tree commit diff
path: root/hosts/phobos/hardware/laptop/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/phobos/hardware/laptop/disks.nix (renamed from hosts/phobos/disks.nix)14
1 files changed, 13 insertions, 1 deletions
diff --git a/hosts/phobos/disks.nix b/hosts/phobos/hardware/laptop/disks.nix
index 2927fe5..07618df 100644
--- a/hosts/phobos/disks.nix
+++ b/hosts/phobos/hardware/laptop/disks.nix
@@ -1,5 +1,17 @@
 { config, lib, inputs, pkgs, modulesPath, isIso, ... }:
 {
+
+  environment.persistence."/persist" = {
+    directories = [
+      "/var/log"
+      "/var/lib"
+    ];
+    files = [
+      "/etc/machine-id"
+      "/etc/nix/id_rsa"
+    ];
+  };
+
   fileSystems."/" = {
     device = "none";
     fsType = "tmpfs";
@@ -33,7 +45,7 @@
 
   swapDevices = [ ];
 
-  services.btrfs.autoScrub.enable = if !isIso then true else false;
+  services.btrfs.autoScrub.enable = true;
 
   zramSwap.enable = true;