about summary refs log tree commit diff
path: root/hosts/phobos/hardware/laptop/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/phobos/hardware/laptop/hardware.nix')
-rw-r--r--hosts/phobos/hardware/laptop/hardware.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/hosts/phobos/hardware/laptop/hardware.nix b/hosts/phobos/hardware/laptop/hardware.nix
deleted file mode 100644
index cbec828..0000000
--- a/hosts/phobos/hardware/laptop/hardware.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ config, lib, inputs, pkgs, modulesPath, ... }:
-let
-  powerMode = "performance";
-in
-{
-  imports = [
-    ./disks.nix
-  ];
-
-  boot = {
-    initrd = {
-      availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" "sdhci_pci" ];
-      kernelModules = [ ];
-    };
-    kernelPackages = pkgs.linuxPackages_zen;
-    kernelModules = [ "kvm_intel" ];
-    extraModulePackages = [ ];
-    kernelParams = [ "net.ifnames=0" "biosdevname=0" "iomem=relaxed" "mitigations=off" ];
-  };
-
-  powerManagement.cpuFreqGovernor = powerMode;
-
-  services = {
-    xserver = {
-      videoDrivers = [ "nvidia" ];
-
-      # Enable touchpad support (enabled default in most desktopManager).
-      synaptics = {
-        enable = true;
-        palmDetect = true;
-        twoFingerScroll = true;
-        minSpeed = "1.0";
-        maxSpeed = "1.12";
-        accelFactor = "0.01";
-      };
-    };
-  };
-
-  hardware = {
-    opengl = {
-      enable = true;
-      driSupport = true;
-    };
-
-    nvidia = {
-      prime = {
-        sync.enable = true;
-
-        # Bus ID of the NVIDIA GPU. You can find it using lspci, either under 3D or VGA
-        nvidiaBusId = "PCI:1:0:0";
-
-        # Bus ID of the Intel GPU. You can find it using lspci, either under 3D or VGA
-        intelBusId = "PCI:0:2:0";
-      };
-    };
-  };
-
-}