about summary refs log tree commit diff
path: root/hosts/vm/hardware/virtualbox/disks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vm/hardware/virtualbox/disks.nix')
-rw-r--r--hosts/vm/hardware/virtualbox/disks.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/hosts/vm/hardware/virtualbox/disks.nix b/hosts/vm/hardware/virtualbox/disks.nix
deleted file mode 100644
index 6ba15ec..0000000
--- a/hosts/vm/hardware/virtualbox/disks.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ config, lib, inputs, pkgs, modulesPath, ... }:
-{
-
-  environment.persistence."/persist" = {
-    directories = [
-      "/var/log"
-      "/var/lib"
-    ];
-    files = [
-      "/etc/machine-id"
-      "/etc/nix/id_rsa"
-    ];
-  };
-
-  fileSystems."/" = {
-    device = "none";
-    fsType = "tmpfs";
-  };
-
-  boot.initrd.luks.devices."encrypted_boot".device = "/dev/disk/by-partlabel/boot";
-
-  fileSystems."/boot" = {
-    device = "/dev/mapper/encrypted_boot";
-    fsType = "vfat";
-  };
-
-  fileSystems."/boot/efi" = {
-    device = "/dev/disk/by-partlabel/efi";
-    fsType = "vfat";
-  };
-
-  boot.initrd.luks.devices."encrypted_root".device = "/dev/disk/by-partlabel/root";
-
-  fileSystems."/nix" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=nix" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/persist" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    neededForBoot = true;
-    options = [ "subvol=persist" "compress-force=zstd" "noatime" ];
-  };
-
-  fileSystems."/home" = {
-    device = "/dev/mapper/encrypted_root";
-    fsType = "btrfs";
-    options = [ "subvol=home" "compress-force=zstd" ];
-  };
-
-  swapDevices = [ ];
-
-  zramSwap.enable = true;
-
-}