about summary refs log tree commit diff
path: root/shells/c*.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--shells/c*.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shells/c*.nix b/shells/c*.nix
new file mode 100644
index 0000000..0bc3a48
--- /dev/null
+++ b/shells/c*.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> { } }:
+pkgs.mkShell {
+  name = "c*-shell";
+  buildInputs = with pkgs; [
+    gdb
+    valgrind
+    gcc
+    clang
+    cmake
+    ninja
+  ];
+}