about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-14 17:16:46 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-14 17:16:46 +0200
commitc8b497050304f121ca2c7cb2d6532dde3c07094a (patch)
tree4e6601545c78d938444ea774629c35dc68cb5bd3 /flake.nix
parentAdded physics speedup option (diff)
downloadOSLS-c8b497050304f121ca2c7cb2d6532dde3c07094a.tar.gz
OSLS-c8b497050304f121ca2c7cb2d6532dde3c07094a.tar.bz2
OSLS-c8b497050304f121ca2c7cb2d6532dde3c07094a.zip
Add nix tooling
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..74fd650
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "baitinq.github.io flake";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./shell.nix { inherit pkgs; };
+        }
+      );
+
+}