about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-19 19:17:39 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-19 19:22:59 +0200
commit91908acf406aee1381089e2340ce7061077a0334 (patch)
tree918f332a7008e0c4766543d52fd2e4c2dd20c513 /flake.nix
downloadOSSE-91908acf406aee1381089e2340ce7061077a0334.tar.gz
OSSE-91908acf406aee1381089e2340ce7061077a0334.tar.bz2
OSSE-91908acf406aee1381089e2340ce7061077a0334.zip
Initial Commit!
This is the initial commit for this experiment of a search engine. I
hope I can learn a lot from this!
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..74fd650
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "baitinq.github.io flake";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./shell.nix { inherit pkgs; };
+        }
+      );
+
+}