about summary refs log tree commit diff
path: root/indexer/Cargo.toml
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-25 12:41:10 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-25 12:47:32 +0200
commit4a74cc4691fe11589e15040012988fd84a368cb5 (patch)
treee38de66b4f640febe690b52e4de599eba73586f1 /indexer/Cargo.toml
parentIndexer: Add "correct" error handling (diff)
downloadOSSE-4a74cc4691fe11589e15040012988fd84a368cb5.tar.gz
OSSE-4a74cc4691fe11589e15040012988fd84a368cb5.tar.bz2
OSSE-4a74cc4691fe11589e15040012988fd84a368cb5.zip
Indexer: Use CrawledResource structure as values in the reverse index db
This will allow us to integrate priorities and other improvements.
Diffstat (limited to 'indexer/Cargo.toml')
-rw-r--r--indexer/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/indexer/Cargo.toml b/indexer/Cargo.toml
index c77dc8f..f86c656 100644
--- a/indexer/Cargo.toml
+++ b/indexer/Cargo.toml
@@ -10,6 +10,7 @@ actix-web = "*"
 serde = { version = "1.0", features = ["derive"] }
 scraper = "0.12.0"
 html2text = "0.4.3"
+rand = "0.7.3"
 
 [[bin]]
 name = "indexer"