summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2024-12-07 01:32:26 +0100
committerBaitinq <manuelpalenzuelamerino@gmail.com>2024-12-07 01:34:40 +0100
commit6e452923d0aef460d6e38dfe50a05be15642f2ac (patch)
treeb3fb6dc22920b5a0a2f507278bbf37e33cff562b /flake.nix
downloadaoc-2024-6e452923d0aef460d6e38dfe50a05be15642f2ac.tar.gz
aoc-2024-6e452923d0aef460d6e38dfe50a05be15642f2ac.tar.bz2
aoc-2024-6e452923d0aef460d6e38dfe50a05be15642f2ac.zip
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..ff7efd9
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,24 @@
+{
+  description = "A very basic flake";
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  };
+
+  outputs = { self, nixpkgs }:
+    let
+      systems = [ "x86_64-darwin" "aarch64-darwin" "x86_64-linux" ];
+      createDevShell = system:
+        let
+          pkgs = import nixpkgs { inherit system; };
+        in
+        pkgs.mkShell {
+          buildInputs = [
+            pkgs.zig
+          ];
+        };
+    in
+    {
+      devShell = nixpkgs.lib.genAttrs systems createDevShell;
+    };
+}