about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-30 01:10:01 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-30 17:35:18 +0200
commit43ed4d71beec1f608b81f7bf6697a6a463296beb (patch)
tree8317f7e3ce7fa17527cc2310fe537a107d593a42 /flake.nix
downloadbaitinq.ml-43ed4d71beec1f608b81f7bf6697a6a463296beb.tar.gz
baitinq.ml-43ed4d71beec1f608b81f7bf6697a6a463296beb.tar.bz2
baitinq.ml-43ed4d71beec1f608b81f7bf6697a6a463296beb.zip
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..74fd650
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "baitinq.github.io flake";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./shell.nix { inherit pkgs; };
+        }
+      );
+
+}