summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e3c7a96..a8665e6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,11 +3,13 @@
 
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+    zig.url = "github:mitchellh/zig-overlay";
   };
 
   outputs = {
     self,
     nixpkgs,
+    zig,
   }: let
     systems = ["x86_64-darwin" "aarch64-darwin" "x86_64-linux"];
     createDevShell = system: let
@@ -18,7 +20,7 @@
     in
       pkgs.mkShell {
         buildInputs = with pkgs; [
-            zig
+            zig.packages."${system}".master
             gcc
             gnumake
             valgrind